道招网的php版本已经升级至php7.1.6,虽然不是最新的,但是到了7.x短时间应该是不需要再升级了。
自己总结的教训是:上次对升级的重视程度不够,自己对php升级这些流程本来就不怎么熟悉(说实话都没有想过要升级),升级后mysqlipdo_mysql扩展没有处理好,导致php无法和mysql通信。

经过最近自己的几次倒腾已经网上查阅资料,对php升级已经安装扩展有了更深层的认识,现在反倒比较喜欢直接编译php的源代码来进行安装了,这种安装方式不存在卸载难的问题,缺点就是花的时间有点多。但是后续用phpize安装扩展很方便。

我的升级php之旅主要是安装这篇文章《CentOS7.3编译安装php7.1》的执行了,一切很顺利,没有出现提到的“开启--enable-opcache=on 的错误提示”,反倒是出现了bison is required to build PHP/Zend when building a GIT checkout!的问题,直接yum install -y bison就解决了。最终升级完了仍然无法使用mysql,文章底下的一楼评论很靠谱,在这里感谢文章作者和一楼评论者。


发表评论

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据