于2019年02月20日21点左右,想在vps上面安装phpMyAdmin方便自己管理数据库,但是发现phpMyAdmin提示

PHP 5.5+ is required. 
Currently installed version is: 5.4.45

于是进行了升级,一不小心就升到了比较新的php7.x,貌似一切安好,但是无法新建文章,只有跳到这个url就提示500错误,但是新建媒体等其他的都可以,懒得解决就换成了php5.6.x,问题更严重,直接网址都无法打开,之后的时间就是在不断的折腾,主要的问题是无法连接本站的数据库(docker容器内),但是自己的另一个网站 https://www.daozhao.com.cn 连接的是同一个数据库,确没有问题,自己尝试了多种方法,比如,降级到之前的5.4.x,还是无果,包括编译了几个版本的php还是不行。网上还有谁最新的php默认都没有mysql扩展了,WordPress这边还没有升级跟上。。。
最终的结果呢,到现在也不行,但是我发现直接连我的主机上的数据库是没有问题的,虽然心里很不甘,喜欢连接docker里面的mysql,但是最终还是妥协了。让网站正常运行才是正经事,改天再折腾。。。

分类: 吐槽

1 条评论

普若木特 · 2019/03/02 12:37

现在已经升级到php7.1.6了,php5.x都要没人维护了吧(虽然太多网站还没有升级)

发表评论

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据