道招

报错node-sass version 6.0.1 is incompatible with ^4.0.0

如果您发现本文排版有问题,可以先点击下面的链接切换至老版进行查看!!!

报错node-sass version 6.0.1 is incompatible with ^4.0.0

有时候容易不经意间切换了node版本,升级了node-sass, 然后在跑一些老项目就容易出现这样的报错。

file

查看node-sass的版本就是6.0.1依然很可能报,没问题啊,这个4.0.0是哪里来的?

百度随便搜下node-sass version 6.0.1 is incompatible with ^4.0.0.指的就是,排在前面的很多文章会说node版本和node-sass的版本不一致,一般都是会你升级node-sass版本,要么降级node版本,会提到node-sass官网给出的node-sass和node版本的对应关系 file

node-sass官方给的这个是没错的,只是网上的文章给的答案不全面,因为及时你的node版本是16+,node-sass的版本是6.0.1依然很可能报 node-sass version 6.0.1 is incompatible with ^4.0.0.,这是为什么了?

因为sass-loader,它的版本和node-sass不一致,报错信息的^4.0.0很可能指的就是sass-loader的版本,它们的版本也需要一致的,一般来说它们的大版本一致就可以了,我通常会在npm上看它们的版本关系。

  • 根据node版本确定node-sass的版本 file

file

node16+版本就用node-sass6+版本最新的6.0.1就行了。

  • 根据node-sass版本确定sass-loader的版本

file

node-sass6+版本就用sass-loader6+版本最新的6.0.7就行了。

现在node => node-sass => sass-loader它们三个的版本都匹配,重新npm install就好了。

更新时间:
上一篇:下一篇:

相关文章

关注道招网公众帐号
联系博主